HTTPS Sites and Windows Vista/IE7

Sometimes some HTTPS sites don’t work with Vista/IE 7 resp. bring an Error ‘Internet Explorer cannot display the page’ (internally the HTTP Protocol brings the error ‘ERROR_INTERNET_SECURITY_CHANNEL_ERROR’).

To let that sites work too onto your ‘shiny’ Vista, there are tips like enabling DES encryption over SSL/TSL, change the User Agent string to MSIE 6 etc…

But a easy way is this:

Navigate to  \Tools\Internet Options\Advanced inside of Internet Explorer 7 

Uncheck the ‘Use TLS 1.0’ option and check the ‘Use SSL 2.0’ and ‘SSL 3.0’

Advertisements
This entry was posted in Uncategorized. Bookmark the permalink.

4 Responses to HTTPS Sites and Windows Vista/IE7

  1. Arno says:

    Thank you ! It worked for me !

  2. Selva says:

    Awesome. worked for me as well.

  3. Ravi Rathore says:

    worked for me …… i have to uncheck TLS 1.2 …. useing IE 11 and the other device is Array Loadbalacer (ssl offloading happening there ) then server om plain 80 .

  4. Ravi Rathore says:

    worked for me … thanks ….. i have to uncheck TLS 1.2 . windows 8.1… using IE 11 and the other device is Array Loadbalacer (ssl offloading happening there ) then server on plain 80 .

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s